Wifi su 2 piani - Router Wifi o access point?

Ciao ragazzi, sono nuovo del forum.
Vi scrivo per chiedervi informazioni in merito ad un acquisto che dovrò effettuare.
Ho la necessità di realizzare una rete su 2 piani, e di avere su entrambi connessione internet, sia tramite wifi (con ampia copertura), sia tramite ethernet.
Quindi ho pensato di acquistare il modem router TD-W8961ND per avere così connessione internet e coprire la rete in wireless e in ethernet sul primo piano.
Per il secondo piano, ho pensato di collegare un secondo dispositivo (access point o router wireless) tramite cavo ethernet al modem router TD-W8961ND del primo piano, avendo così anche qui un’ampia copertura wifi e connessione internet. (Da premettere che non posso utilizzare powerline ecc…)
Avendo però la necessità di collegare al secondo piano, non solo pc in wifi, ma anche pc via ethernet, non so che dispositivo è più indicato acquistare, se un router wifi o un access point (ho notato che gli access point non hanno più porte ethernet, ma una sola porta). Quindi vi chiedo se potete darmi delucidazioni in merito, che dispositivo e modello mi consigliate di acquistare.
Grazie

come hai ben notato, se acquisti un AP devi abbinarci uno switch (10€), quindi ti conviene un router. visto che non ti serve che abbia il modem adsl al secondo piano puoi andare su quelli della serie wrXXXXX, ad esempio il wr841nd, se non ti interessa la rete gigabit.

Per il modem/router evita il w8961 e il suo fratellino w8951, prendi il w8960n è molto più stabile e prestante per pochissimi € di differenza :wink:

Ti ringrazio per le indicazioni, non sapevo che il w8960n fosse più stabile, per il primo piano allora è andata per il w8960n :wink: Per quanto riguarda il router al secondo piano, ho visto che sono tutti simili, avevo pensato di acquistare il modello TL-WR743ND dove è l’unico router che dice di avere anche funzioni di access point (anche se è da 150 MB penso che non dovendo trasferire file, ma condivdiere solo internet, vada più che bene). Gli altri modelli sinceramente non li conosco e non so se sono più indicati… Tu sapresti indicarmi per quanto riguarda il router/access point, il modello più indicato alle mie esigneze? Grazie ancora.

no allora… qualsiasi router puo’ fare da access point.
e per access point intendo creare una rete wifi, e metterla in comunicazione con una o più porte ethernet.
il wr743nd in più degli altri ha la funzione AP CLIENT, cioè collegarsi via wifi ad un’altra rete già esistente! cosa che gli altri possono fare solo con il wds, se compatibile con l’altro router.
nel tuo caso se hai un cavo ethernet tra i 2 router, va bene un router QUALSIASI.
le differenze tra i vari modelli sono nella velocità della rete cablata (gigabit è 10 volte più veloce), e/o nella presenza della porta usb per condividere in rete dischi e chiavette.
quello che ti ho consigliato prima (wr841nd) va benone :wink:

webdany ho cancellato le altre discussioni, perchè non hai postato anche nella sezione “Offerte TP-LINK” ?
… mancava solo quella :stuck_out_tongue:

Si infatti, mi sa che una sezione bastava…

Nebbia88 grazie per i consigli, ho deciso per i 2 modelli che mi hai indicato :wink: Come configurazione confermi la seguente? Modem Router primo piano 192.168.2.1 - DHCP Abilitato - DNS del provider internet. Router secondo piano: 192.168.3.1 - DHCP abilitato DNS provider 192.168.2.1. Ho pensato di configurare così il tutto, non so se è giusto. Non so però se il secondo router va messo in bridge mode, o in altre configurazioni. Grazie ancora :wink:

sì, è più comodo fare un’unica subnet, collegando i 2 router tra porte LAN.
Sul secondo router disabiliti il DHCP e gli dai un ip nella stessa subnet del primo tipo 2.2 :wink:

Ok, ma disabilitando il dhcp al secondo router, tutti i pc o dispositivi che si collegheranno ad esso, non potranno collegarsi più direttamente, ma dovrò impostare manualmente su ogni dispositivo, l’indirizzo ip, dns ecc… Inoltre mettiamo il caso che assegnassi quindi manualmente ad un pc del secondo router 192.168.2.3 , sul primo piano dove c’è il primo modem/router con dhcp abilitato, potrebbe esserci il rischio che al primo piano a qualche pc gli venga assegnato un indirizzo ip uguale a qualche pc del secondo piano, tipo 192.168.2.3 ecc… poi non potrebbero esserci conflitti con ip uguali dovuti al dhcp abiliato, ed al secondo dhcp disabilitato?

certo che no.
essendo collegati via LAN tutti i pacchetti vanno su entrambi i router, i pc collegati al secondo prendono un ip dal dhcp del primo.
il range di default parte da 100, qunidi non avrai problemi se dovessi impostare ip statici usi i numeri da 2 a 99 :wink:

Ecco Nebbia88, questa è un immagine riepilogativa di cio che ho intenzione di fare, oggi ordino i 2 dispositivi che mi hai consigliato. Avevo pensato anche ad un’altra soluzione: di usare al posto del router wifi WR841ND, uno switch collegato al primo router/modem W8960N tramite ehternet. Allo switch poi vorrei collegare un access point per coprire il wifi sul secondo piano e sulle altre porte dello switch potrei collegare alcuni pc che dovranno utilizzare l’ehternet e non il wifi. Ma paradossalmente ho notato che mi costa di più acquistare un access point ed uno switch, che acquistare il router da te indicato. Quindi vada per la prima soluzione da te indicata.

non è paradossale che costi di più, devi pensare che il costo di case, alimentatore, sezione di alimentazione sulla scheda, sarebbe tutto “doppio” comprando un AP + Switch.
molto più ovvia la soluzione “router usato come AP + Switch” :wink:
Per l’adattatore wifi del pc fisso al primo piano ti consiglio la wn722n, se non ne hai già una :wink:

P.S. cosa usi per creare quegli schemi? è stupendo!

Sono tutti notebook con wifi integrato, quindi per fortuna non devo acquistare anche l’adattatore Wifi :wink: I pc fissi li ho messi per dare un idea dello schema. Cmq ho preso un’immagine che ho trovato sul web, dove c’erano già disegnati quei pc, frecce ecc. e l’ho modificata con photoshop :wink:

ah ecco perche’ c’era un fisso con il wifi :stuck_out_tongue:

Ciao a voi!

Anche io ho lo stesso problema…

Ho comprato la coppia TP-W8961ND + TP-WR-1043ND.
Vorrei “solo” estendere il mio range wireless in casa.

Senza troppi pensieri li ho presi pensando: stessa marca, wds… Caso chiuso.

Non riesco a configurarli neanche con le bombe atomiche :frowning:

Avete qualche guida o suggerimento?

Ho anche provato installato dd-wrt sul router ma niente anzi peggio: 12000 opzioni al secondo e nessuna idea su dove mettere mano.

beh se sei riuscito a installare dd-wrt senza rompere nulla è già un buon inizio!
devi seguire alla lettera questo tutorial:

http://www.dd-wrt.com/wiki/index.php/Client_Bridge

e dovresti riuscire a navigare dalle porte lan del wr1043nd collegato alla wifi dell’altro.

poi devi abilitare un VAP per “ricreare” il wifi, ma ci penseremo più avanti ^^

P.S. ormai è scritto ovunque ma lo ripeto: avresti fatto meglio a prendere il W8960N :wink:

:open_mouth:

Astuto! :smiley:

Avevo bocciato quest’idea proprio perchè mi sarei giovato solo delle porte lan…
Invece aggiungendo un’interfaccia virtuale si chiudono i giochi! :smiley:

Questa sera torno a casa - ri-flasho dd-wrt che in un momento di pazzia mi ha fatto innervosire e avevo rimesso il firmware di base - e seguo il primo tutorial passo-passo.

Devo fare qualche danno anche sul modem-router o posso lasciarlo allegramente così come è?

sul W8960N devo dire a mia discolpa che avevo solo intuito il buon rapporto prezzo/qualità tp-link e quindi avevo deciso di acquistare questo brand.
Sono andato dal mio hardwaraiolo di fiducia e gli ho detto: voglio il tp-link modem/router più fico, caro e profumato che hai.
50 euro.
Ero contento, insomma.
Poi ho scoperto orrori insondabili del tipo la puzza di plasticone cancerogeno (ma questo non fa nulla) i chipset di marca diversa da router a router (sempre tp-link) che vanificano gli sforzi di implementare correttamente WDS…
Però con la fortuna che il 1043 sembra un bell’aggeggino (e pertanto supporta anche dd-wrt), con qualche saggio come te e con un po’ di pazienza…
Magari risolvo uguale :smiley:

mi raccomando fai con calma le procedure di flashing… segui la guida qui:

https://www.in-rete.it/viewtopic.php?t=6

in teoria sul modem/router non devi toccare nulla, una volta impostata la protezione (possibilmente wpa2 aes) :wink:

:frowning:

Ogni giorno che passa aumenta la frustrazione diminuiscono i risultati.

Ho provato, visto che avevo riflashato il software tp-link, a configurare il wds “tutto tp-link”.
Nulla.
Nel senso che nella schermata wds status mi segna “run” ma in concreto non funziona.
Ho cercato di copiare i dettagli inerenti il wireless con gran precisione ma niente…
Neanche con i router a 10 cm di distanza.

Poco male: riflash dd-wrt e riparto resettando di fabbrica sia il modem-router che il router.

Lento come una formica configuro il modem per uscire su internet con alice: tutto ok.
Scelgo di tenere la rete “open” per non avere problemi relativi alla sicurezza e vedere, anche solo una volta, tutto che funziona.
Il lato modem pare andare come un fischietto.

Passo al router con dd-wrt e seguo scrupolosamente il tutorial che mi hai segnalato per fare il client bridge e giovarmi della funzionalià di navigazione SOLO per ethernet sul router.

Infiniti click e riavvii dopo, spalleggiato dalla mia ragazza e da mio fratello per avere 6 occhi al posto di due sui parametri ecco la luce: il server dhcp funzionante sul modem assegna un indirizzo ip al client attaccato con ethernet al 1043.
Ping: ok.

Allacciato con ethernet al 1043 pingo 192.168.1.2 e 192.168.1.1 e rispondono.
Il ping è molto altalenante (l’host non risponde ogni tanto ai pacchetti) ma c’è.
I router sono NELLA STESSA STANZA ma il segnale (dal lato diagnostica wireless dd-wrt) è 70%).
Cambio i settaggi di rete su modem e modem router e verifico (o forse ero solo ormai ottenebrato) che funzionando solo in “N” il ping sembra più stabile.
Provo a navigare usando ethernet —> 1043 —> wireless —> modem ----> internet: naviga.

Salto di gioia, stappo prosecchi.

Pochi minuti dopo non funziona più.

Rispengo i router e va.

Poi non va più. Sembra che tutto funzioni se il vento tira da nord è l’umidità è superiore all’11%.
Ma solo se sei nel parco nazionale dello stelvio.

Ora io voglio bruciare tutto e poi spaccare quanto rimasto in pezzi minuscoli ma…
Vorrei capire.

Cosa non va e perchè.

Ci sono dei log?
Come posso fare debugging?
Ormai non m’importa neanche dei soldi spesi, non m’importa più di avere una rete a casa, non m’importa più di internet.

Voglio capire come funziona questa cosa.

Tanto per iniziare, capendo del nulla che ho chisto finora: come faccio ad esser certo di aver riportato dd-wrt alle condizioni “di fabbrica”? Col tasto di reset posteriore sembrerebbe che tutto sia di nuovo vergine (mi chiede di nuovo di settare la pwd di admin) però se poi scartabello nei settaggi trovo cose che avevo cambiato io prima del reset.

Vorrei esser certo di aver dd-wrt vergine e ben funzionante per poi rieseguire passo passo il tutorial per fare client bridging.

Per pietà aiutatemi prima che vada a comprare un martello.

mmm… hai provato con la wpa2 aes? come consigliato nel tutorial…

http://www.dd-wrt.com/wiki/index.php/Repeater_Bridge#Atheros

poi qui han parlato un po’ delle varie sicurezze… e c’è il fatto che va riavviato 2 volte che mi ero scordato!
qualcuno dice di abbassare il key renewal a 15 secondi…

dopo tutto cio’, ho letto molte volte che client (non bridge) e quindi repeater (non bridge) funzionava meglio, almeno nelle prime build, quindi non so se sia quello il tuo problema, pero’ farei un tentativo :wink:

http://www.dd-wrt.com/wiki/index.php/Wlan_Repeater#Atheros_Considerations


P.S. il tentativo con il firmare originale te lo potevi risparmiare, il trendchip+ralink del modem non andrà mai d’accordo con l’atheros ^^
se invece era un w8960n (broadcom) funzionava, pero’ al massimo con protezione wep, quindi avresti dovuto comunque usare dd-wrt se volevi la wpa :stuck_out_tongue:

P.P.S. stai caaaaalmo! ^^

P.P.S. per il reset… ma non puoi farlo dall’interfaccia di dd-wrt?? Administration-Factory Defaults.