Script JDownloader TP-LINK TD-W8951ND

Salve sono nuovo del forum e spero di aver scelto la sezione giusta, il problema è che non riesco a trovare uno script per la riconnessione con JDownloader adatto per il mio router TP-LINK TD-W8951ND, ho cambiato da poco il mio vecchio D-Link G624T, ed è da un paio di giorni che cerco ma senza risultato spero che qualcuno possa aiutarmi grazie in anticipo.

Cordiali Saluti

se nessuno qui in giro ce l’ha, puoi tranquillamente fare “crea script” e creartelo.

il problema è capire il modo più veloce per fare cambiare ip pubblico al router.

a occhio e croce direi che puoi entrare nella config, andare su Interface Setup, Internet, e che ne so, mettere “connect manually”, salvare, rimettere automatic, risalvare.

per verificare se il tuo ip pubblico cambia (senza dover usare jdownloader) basta andare su http://www.whatismyip.com/

fammi sapere dove ti perdi :wink:

P.S. si puo’ fare più semplicemente con uno script telnet… ma non l’ho mai fatto dovrei andare un po’ a tentativi…

grazie dell’aiuto ho fatto come hai detto tu (avevo provato anche io a farlo prima seguendo una guida ma non trovavo quello che mi chiedeva) ora cambia “magicamente” ip grazie ancora di seguito posto il mio script ne caso serva a qualcuno Modello TP-LINK TD-W8951ND

[[[HSRC]]]
    [[[STEP]]]
        [[[REQUEST]]]
        GET / HTTP/1.1
        Host: %%%routerip%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET / HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /status.html HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /navigation-status.html HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /status/status_deviceinfo.htm HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /js/general.js HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /status/status_deviceinfo.htm HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /status/status_deviceinfo.htm HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /status/status_deviceinfo.htm HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /status/status_deviceinfo.htm HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /status/status_deviceinfo.htm HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /status/status_deviceinfo.htm HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /basic/home_wan.htm HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /navigation-basic.html HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /js/general.js HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /basic/tc2wanfun.js HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /basic/home_wan.htm HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /js/general.js HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /basic/tc2wanfun.js HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /basic/home_wan.htm HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /js/general.js HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /basic/tc2wanfun.js HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        POST /Forms/home_wan_1 HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%

HiddenFlag=0&wan_VC=PVC0&wanVCFlag=0&wan_VCStatus=1&Alwan_VPI=8&Alwan_VCI=35&Alwan_QoS=UBR&wan_PCR=0&wanConTypeFlag=0&wanTypeRadio=Two&wan_PPPServicename=infostrada&Allow_Empty_Flag=1&Check_UsrPsw_Flag=0&Empty_UsrPsw_Flag=0&Check_PasswordFlag=0&wan_PPPUsername=benvenuto&wan_PPPPassword=ospite&wan_PPPEncap=PPPoE+LLC&PPPoEBIStatus=0&wan_ConnectSelect=Connect_Keep_Alive&wan_TCPMSS=1400&wan_PPPGetIP=0&wan_NAT=Abilitato&WAN_DefaultRoute=1&wan_TCPMTU=1480&wan_RIPVersion=RIP1&wan_RIPDirection=Nessuno&wan_IGMP=Disabilitato&wan_EnabledSpoof=0&BridgeFlag=0&wanIGMPQitFlag=0&wan_PVCO_Flag=0&PageLockValue=0
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /basic/home_wan.htm HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /js/general.js HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

    [[[STEP]]]
        [[[REQUEST]]]
        GET /basic/tc2wanfun.js HTTP/1.1
        Host: %%%routerip%%%
        Authorization: Basic %%%basicauth%%%
        [[[/REQUEST]]]
    [[[/STEP]]]

[[[/HSRC]]]

ottimo!!

P.S. occhio a postare gli script… nel tuo caso non c’è problema, perche’ user e pass PPP sono uguali per tutti “benvenuto” e “ospite”, se avessi avuto che ne so tiscali, ci sarebbe stata la tua mail e password!!

ahahahaahah avevo dato uno sguardo allo script per vedere se ci stavano dati personali ma non ce ne stavano grazie cmq dell’informazione non se ne sa mai abbastanza :slight_smile:

Ciao a tutti, sono nuovo del forum :shy: e ho lo stesso problema col mio router…

Stesso modello, Firmware Version:
1.0.0 Build 110907 Rel.08257

Solo che mancano le voci “connect manually” e “connect automatic”. Inoltre se Provo ad ottenere l’IP del router con jDownloader mi dice: Impossibile trovare l’IP del router… non riesco a capire come risolvere, non sono molto esperto… Qualcuno saprebbe dirmi come risolvere? grazie mille. Saluti a tutti.

strano firmware, non lo trovo nel sito ^^

ma sei entrato su http://192.168.1.1 ?
l’ip del router è appunto quello… 192.168.1.1

ho dovuto aggiornare il firmware poiché il precedente non era compatibile con windows 7. Ma ho seguito le istruzioni sul sito e sembra funzionare a meraviglia…

Per quanto riguarda l’ip mi sembra veramente strano che non me lo trovi JD…

questa mi mancava, un router non compatibile con Win 7 -.-

i router sono compatibili per definizione, usano lo standard Ethernet, qualsiasi Sistema Operativo funziona.

forse tu provavi a installarlo con il CD fornito?

Ce l’ho fatta !!! :smiley: non so per quale motivo ma Encapsulation era impostato su Bridge Mode… per questo motivo non vedevo le voci di connessione manuale ed automatica… Non me ne ero accorto perché funzionava tutto alla perfezione :huh: JD ancora non mi trova l’ip del router, ma l’ho inserito manualmente, ho seguito le vostre istruzioni e funziona :shy:

Lo pensavo anche io… eppure quando ho installato win 7 ha iniziato ad avere problemi di disconnessione frequenti che con xp e linux non avevo… il venditore mi ha detto di aggiornare il firmware e da quando l’ho fatto si è risolto tutto… I misteri dell’informatica… prendiamolo per dogma :smiley:

beh se lo usavi come modem (appunto in Bridge mode) è possibile!!
perche’ dovevi ogni volta creare la “connessione a banda larga” dal pc!

non è così che si usa un router solitamente, anche perche’ altrimenti puoi usare solo un pc contemporaneamente :wink:

grazie per la delucidazione… ma non capisco davvero come si sia selezionata questa opzione … mah… beh, almeno adesso so cosa vuol dire :shy:

Salve,

ho anch’io lo stesso problema, pur avendo seguito il topic non sono riuscito a fare la riconnessione. ho anche provato a copiare direttametne lo script, quando provo a fare test riconnessione mi dice impossibile aprire la pagina.

Ecco uno screen delle impostazioni:

screen

come si vede, l’ incapsulamemento è messo in PPoE/VLC,
l’ISP in PPoA/PPoE.

se provo a metterlo in IP dinamico perdo la connessione a internet…qualche idea?

è tutto giusto.

puoi postare la pagina che ti si apre quando provi lo script?
ad ogni modo ti conviene rifarlo, perche’ nello script ci sono anche le credenziali e i parametri della connessione, o li modifichi dallo script che è stato postato, oppure lo fai da zero con la funzione apposita :wink:

ho riprovato e stavolta è riuscita. grazie cmq!