Problema Configurazione Client TL-WRT743ND

Salve a tutti!
Premetto che ho già cercato, invano , su internet qualcuno che avesse risolto il mio problema ma purtroppo ho trovato solo una discussione obsoleta in questo forum…
Ho acquistato il router in questione qualche giorno fa , dovendo sostituire un altro mio router ( sempre della TP-LINK ) a cui non funzionava più la scheda wireless. Pensavo di poter usare questo nuovo acquisto come client : ho il router abbastanza vicino da camera mia , dove devo collegare (tramite ethernet ) il televisore, il nas ed un computer fisso. Purtroppo già dopo averlo acceso e provato mi sono reso conto che era supportata solo la modalità Client AP e quindi, dopo un’ora e mezzo di tentativi , sono riuscito a configurare una nuova subnet (192.168.2.xxx) e a navigare su internet. Purtroppo le funzioni principali della LAN non sono possibili in questa modalità! Sono quindi andato sul sito e ho scaricato il nuovo firmware :MIRACOLO , ora è supportata la modalità Only Wireless Client. Allora mi sono armato di pazienza, ho aggiornato e ho seguito la configurazione guidata per entrare in modalità Wireless Client assicurandomi però di disattivare il DHCP ( questo router si collega come client in wireless al router principale, sempre della TP-LINK !). Purtroppo dopo svariati tentativi non mi è ancora riuscito di farlo funzionare : senza DHCP il computer non prende indirizzo IP…sembra quasi che il server DHCP del router principale non dialoghi con questo. Premetto che sulla schermata principale del 743 non ci sono errori : il client è in modalità RUN e tutto funziona bene… Tra l’altro, sempre dalla diagnostica del 743 , pingando il 192.168.1.1 (router principale) funziona tutto !!
Dove sbaglio ?

hai provato ad impostare manualmente su un pc collegato un ip della stessa classe del router principale, e pingarlo? hai cambiato l’ip LAN del wr743 in modo che non sia uguale a quello del router principale (es.192.168.1.2)

Ottima notizia che ora ci sia anche il wireless client bridge puro, e anche il repeater!!! FENOMENALI!

Per quanto riguarda la seconda opzione si, ho provato. Internet funziona ma non c’è la LAN quindi non mi serve a niente!
Per la prima opzione ho DOVUTO mettere l’IP fisso (ho utilizzato 192.168.1.132 in modo da evitare di sovrappormi ad altri indirizzi in rete ) altrimenti il computer non si collegava al router! In pratica i computer collegati al TP-LINK sentono solo il DHCP di questo e non quello del router principale…sembra ci sia un errore di comunicazione tra i due router!

sì ma non ho capito se poi una volta impostato l’ip statico i pc vedono il router principale e navigano.
Guarda bene la seconda opzione, ho scritto 1.2, non 2.1!

Scusa , avevo letto male… Il computer che ho utilizzato per fare la prova era impostato su 192.168.1.132 , ip che appartiene alla classe del primo router visto che gli indirizzi vanno da 192.168.1.100 a 192.1.168.150 ! Purtroppo non riuscivo a navigare né a vedere i pc connessi sulla lan del primo router.

avevi impostato anche gateway e dns l’ip del primo router? e l’ip del secondo appunto dev’essere diverso dal primo…
occhio che la “classe” dei router non ha quasi nulla a che vedere con il range del loro server dhcp, quindi sui pc puoi anche impostare 1.10 o 1.20, non serve siano tra 100 e 150.

Allora , ripartiamo da capo :smiley:
Dopo aver aggiornato il firmware ho fatto le seguenti cose , in ordine :

  1. Cambiato l’indirizzo IP del secondo router in modo che non corrispondesse con quello principale ( ho messo 192.168.1.149 ).
  2. Reboot
  3. Setup Wizard in modalità Wireless Client
  4. Impostato parametri di connessione al router principale : password, rete e nazione.
  5. Reboot
  6. Disattivato DHCP
  7. Reboot :dodgy:
  8. Collegato Computer Con Ethernet : in modalità automatica purtroppo non riusciva a connettersi ( e già qui la cosa sembra strana… ) ; impostato pc su 192.168.1.132 ma purtroppo non si riesce a navigare né su internet né in LAN.

I parametri a cui ti riferisci ( gateway e dns ) vanno impostati sul computer o sul router ? Per quanto riguarda la seconda opzione probabilmente ti riferisci alla scheda “WAN” della pagina di configurazione che è stata rimossa in questo firmware, esclusivamente nella modalità Wireless Client.
Altra cosa singolare : nonostante sia in modalità Wireless Client trasmette SSID della sua rete ( Tp_link…) , quindi presumo ci sia qualche errore nel firmware…:huh: Perchè dovrebbe fare da Access Point se è in modalità Client ? :huh:
Grazie in anticipo per la pazienza

Mi riferivo alla configurazione della scheda di rete del pc!
Se dalla diagnostica del router riesci a pingare l’altro vuol dire che il client funziona, sarebbe molto strano non ci riuscissi da un pc collegato.

Se il problema fosse SOLO che non comunicano col server dhcp del primo router basterebbe lasciare abilitato anche il secondo su un range diverso, e ovviamente impostandogli come gateway e dns l’ip del primo router (su dhcp settings).

Per l’ultima cosa, potrebbe tranquillamente fare sia da client che da AP con il suo SSID…

dimenticavo, il canale wifi è impostato fisso e uguale su entrambi i router?

Mi sembrava strano anche a me infatti…

Questo non l’ho ancora provato… Per Range intendi ? Che tipo di IP ?

Non si può impostare ! ( nel secondo parlo ovviamente ) Dalla pagina di status si vede che fa automaticamente uno scan del wifi e individua il canale su cui tramsette il router principale!

intendo un range tipo 1.200-1.250.

Ovviamente non si puo’ impostare il canale, cavolata mia :wink:
P.S. ma il router principale che modello è??

Il mio dubbio è : come fa il primo router a riconoscere i computer connessi al secondo se sono in un range fuori dal suo DHCP ?
Comunque ora provo.

Il router principale è il TD-W8961ND !

Con il tuo ragionamento se io disabilito il dhcp il router non “riconoscerebbe” più nulla XD
Come ho scritto prima, stai confondendo il concetto di “sottorete” impropriamente chiamata “classe” con il range su cui il server dhcp assegna indirizzi.

Niente da fare per quanto riguarda il metodo che mi hai suggerito : stavolta non pinga neanche il 192.168.1.1 Ti posto gli screen per far vedere le impostazioni . ( ho controllato ora : con il DHCP disabilitato pinga 192.168.1.1 , altrimenti no )
http://imageshack.us/photo/my-images/856/screen1ii.jpg
http://imageshack.us/photo/my-images/20/screen2tid.jpg/
http://imageshack.us/photo/my-images/850/screen3l.jpg/

mmm… mi pare abbastanza buggoso il fatto che con il dhcp abilitato non funzioni più il client… MAH.
Ah ovviamente non hai mac filtering abilitati sul router…
Fai una prova con la rete wifi senza password ma ho i miei dubbi che cambi qualcosa.
Non saprei cos’altro farti provare! Senti l’assistenza se non l’hai già fatto…
Al di là di tutto quest’argomento, cos’è che non riuscivi a fare con la modalità ap client router?
Perche’ tu dici “Purtroppo le funzioni principali della LAN non sono possibili in questa modalità!” che mi pare un po’ eccessivo, nel senso che tra gli apparecchi collegati allo stesso router si vedono perfettamente, e riescono anche ad accedere a quelli sul router principale.
L’unica cosa che non funziona è di non poter accedere singolarmente a quelli collegati al secondo router da un client collegato al primo, pero’ per esempio puoi renderne visibile uno (esempio il NAS che è il più utile credo) usando la funzione DMZ.
Ne avevamo parlato qui, anche se immagino l’avessi già visto:

https://www.in-rete.it/viewtopic.php?t=170

inviata mail…spero mi rispondano …
Non capisco perchè siano così difficili da configurare questi prodotti!
Ho altri 3 tp-link e ho perso parecchio tempo prima di riuscire a farli funzionare a dovere

normalmente non sono affatto difficili (con le dovute conoscenze), certo se ci si mette di mezzo qualche bug…
Ho avuto esperienze ben peggiori con altri apparecchi di networking… di qualsiasi marca!!

Ancora più dubbi…
Oggi ho provato ad utilizzarlo prima come Wifi repeater ( senza successo, ma me lo aspettavo ) e poi come Access Point Wireless… La mia domanda è : essendoci già un router-modem principale non è possibile attaccare un altro access point ad una porta ethernet del primo per avere un’altra rete WIFI su cui distribuire internet ? ( mi sembrava di averlo già fatto tempo fa…) . Purtroppo non ha funzionato neanche in questa configurazione : mi viene da pensare che abbia un problema di costruzione! Tra l’altro mi è successa la stessa cosa con il Tp-Link vecchio…

certo che puoi collegarlo via cavo al primo, a patto come sempre di cambiare l’ip lan del secondo e disattivare il dhcp (se nemmeno così si prendo ip in automatico dal primo router c’è qualcosa di grosso che ci sfugge…).

Quando dici “non ha funzionato” cosa intendi? la rete wifi la vedi? si collegano ma non navigano? si prendono un ip in automatico?

Il secondo ha ip 192.168.1.149 , diverso dal principale 192.168.1.1 ( ho rimesso il mio buon vecchio Cisco al posto del TP-Link perchè il cellulare non navigava più…-.- ). Ho disattivato il DHCP ma il computer continua a non prendere un IP…!
Da notare che nelle impostazioni WAN si connetteva ( con ppoE) solo quando il DHCP era disattivato. Di nuovo dalla pagina di status sembrava tutto ok ma non caricava nessuna pagina internet… Stessa cosa in Wireless Repeater : collegato, status ok ma niente internet.

perche’ pppoe??? e poi io lo collegherei su una porta LAN non WAN!