Openwrt su TL-WR1043ND

Se n’è parlato un pò in altri thread qui sul forum, ho pensato di aprirne uno nuovo per raccogliere tutte le info e i pareri di chi ha installato o intende installare openwrt su questo router.

Ho trovato diverse guide per installare la versione openwrt 10.03.1-rc4, e in molti dicono che questo sia uno dei migliori router che supportano openwrt.
Un esempio, se mi è permesso è:

Pochi giorni fa è uscita anche la rc5, però ancora non ho letto di nessuno che l’abbia installata.

A voi i commenti.

beh la rc5 era in testing da mesi, direi che puoi essere tranquillo, occhio a prendere il file xxxfactory.bin

http://downloads.openwrt.org/backfire/10.03.1-rc5/ar71xx/openwrt-ar71xx-tl-wr1043nd-v1-squashfs-factory.bin

Non è immediato configurarlo… trovi tutto nella wiki di openwrt ma devi avere un po’ di dimestichezza ^^
Per quel poco che posso aiutare non avendolo provato, sono qui :wink:

effeti l’ha usato per un po’ quindi credo sia possibile risolvere qualsasi problema ti si dovesse presentare ^^

Come per tutti i firmware alternativi ti consiglierei di avere a disposizione l’interfaccia seriale dovesse capitare qualcosa…

Installata la rc5, ancora non ho configurato nulla.
La prima cosa provata è la rete e il download e qui mi sta venendo un forte dubbio.
Provo a scricare una distro di ubuntu, il download parte a 500KB/s, ma man mano scende inesorabilmente anche sotto i 300. Ora non vorrei che sia la mia linea (attiva da pochi giorni- hiperlan) ma non mi sembra che con fw originale/dd-wrt facesse lo stesso.

Se qualcuno lo installa vorrei un riscontro in merito…

attaccati col cavo direttamente al pc senza passare dal router no?

che linea e’?

Ciao nebbia, si infatti poi ho fatto così, e non era problema del router ma è la linea che si comporta così, indagherò!

Pr quanto riguarda le installazioni, allora ho montato il disco in ntfs, abilitato lo swap. E fin qui non ci sono stati problemi.
I problemi sono arrivati installando samba3. Lo installlo, installo la samba-luci-app condivido la dir /home (dove avevo montato il disco), windows 7 vede la directory non mi accede alla dir dicendomi che non ho i permessi. Allora provo a montarlo su /mnt tramite terminale, e accede correttamente. Quindi riavvio il router, ma al riavvio mi ritrovo lo stesso problema di prima, cioè non ho i permessi etc etc.
Vado a guardare i permessi di /mnt, e noto che, paradossalmente, i permessi della dir sono cambiati a “dr-x------”, cioè 500. prima, se non ricordo male erano 777. Ho fatto la prova del nove ed ho cambiato nuovamente directory di mount e di condivisione da terminale, tutto ok, salvo da interfaccia ed al riavvio mi trovo i permessi cambiati!

Inoltre il salvataggio da interfaccia non va più, si blocca dopo il salvatggio di fstab e non mi porta a termine l’operazione.

Non so cosa può essere successo. Avete qualche idea? Forse devo impostare qualcosa da interfaccia? Eppure i file fstab,samba e samba.conf sembrano corretti.

mmmm… una soluzione “brutta” è di mettere uno script all’avvio che ti imposti i permessi ^^
pero’ sarebbe da capire come mai te li cambia da solo…

Bug: https://dev.openwrt.org/ticket/9395
Segnalalo anche tu, cosi si danno una mossa :smiley:

Per samba segui il wiki e non usare luci,
PS. io se non ricordo male ho dovuto usare anche chown

hai letto qui?

https://forum.openwrt.org/viewtopic.php?id=26625

poi dicono che è meglio montarle su una subdir di /mnt…

Ahh … ricordati anche di aggiungere l’opzione umask=000 in fstab

config ‘mount’
option ‘options’ ‘rw,umask=000

Creata nuova dir hdd sotto mnt, dati permessi 777.
In fstab aggiunto in opzioni umask=000.
Adesso i permessi al riavvio sono 555, quindi ok in lettura ma niente in scrittura! Non so come uscirne!

Può essere che ho sbagliato ad istallare qualche pacchetto? Quelli installati sono:
opkg install kmod-usb-storage-extras
opkg install block-mount
opkg install block-hotplug
opkg install kmod-fs-ntfs
opkg install ntfs-3g

Credo il problema sia ntfs… non lo gestisce bene!

RISOLTO!

rimosso il pacchetto kmod-fs-ntfs che serve per montare ntfs solo il lettura, ed impostato in fstab: ‘fstype’ ‘ntfs-3g’.

Prima avevo ‘ntfs’, e quindi usava il modulo del kernel e lo montava solo in lettura! Sono stao ingannato dalla LUCI, che non mi mostrava come tipo del fs ntfs-3g, per cui pensavo bisognasse mettere ‘ntfs’!

Meglio non guararla per niente la luci, porta solo ad errore!! Ma perchè non la sistemano o la tolgono completamente?!

Adesso il mio fstab funzionante è:

config ‘global’ ‘automount’
option ‘from_fstab’ ‘1’
option ‘anon_mount’ ‘1’

config ‘global’ ‘autoswap’
option ‘from_fstab’ ‘1’
option ‘anon_swap’ ‘0’

config ‘swap’
option ‘device’ ‘/dev/sda2’
option ‘enabled’ ‘1’

config ‘mount’
option ‘device’ ‘/dev/sda1’
option ‘target’ ‘/mnt/hdd’
option ‘fstype’ ‘ntfs-3g’
option ‘enabled’ ‘1’
option ‘options’ ‘rw,umask=000’

ottimo :wink: