help tplink3220v1 ripristino firmware originale

saluto tutto il forum :: dopo un aggiornamento il router non risponde +++il problema e che si collega mi da un indirizzo 192.168.1.1 ma niente .sul broswer mettendo lindirizzo ma niente o provato con dei programmi tftpd32 winscp putty file zilezilla qualche consilio .?’

Ciao ti serve l’interfaccia seriale: http://wiki.openwrt.org/toh/tp-link/tl-mr3420#serial

Ti serve sempre la seriale …

buongiorno a tutti una domanda e possibile solo con il cavo seriale ripristinare il router ? grazie

Il router si riavvia da solo? Se non riesci ad accedere l’unico modo è la seriale.
Ricorda che devi saldare anche la resistenza!

To get the serial connection work reliably, you have to connect a 10k pullup resistor between the TX and the 3.3V pin.

cia0 o apena collegato il tutto e mi uscito questo per gli esperti cosa sicnifica vado bene o o o pure?

U-Boot 1.1.4 (Jan 25 2011 - 12:09:11)

AP99 (ar7241 - Virian) U-boot
DRAM:
sri
ar7240_ddr_initial_config(133): virian ddr1 init
#### TAP VALUE 1 = 0xf, 2 = 0x10 [0x0: 0x1f]
32 MB
id read 0x100000ff
sector count = 64
Flash:  4 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7240_enet_initialize...
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
Virian MDC CFG Value ==> 4
: cfg1 0xf cfg2 0x7014
eth0: 00:03:7f:09:0b:ad
eth0 up
Virian MDC CFG Value ==> 4
: cfg1 0xf cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
ATHRS26: resetting s26
ATHRS26: s26 reset done
eth1 up
eth0, eth1
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...



OpenWrt kernel loader for AR7XXX/AR9XXX
Copyright (C) 2011 Gabor Juhos <[email protected]>
Looking for OpenWrt image... found at 0xbf022000
Decompressing kernel... done!
Starting kernel at 80060000...

[    0.000000] Linux version 3.10.24 ([email protected]) (gcc version 4.6.4 (OpenW
rt/Linaro GCC 4.6-2013.05 r39155) ) #1 Sun Dec 22 23:59:53 MST 2013
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR7241 rev 1
[    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:5.000
MHz
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x01ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x01ffffff]
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32
bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pag
es: 8128
[    0.000000] Kernel command line:  board=TL-MR3220 console=ttyS0,115200 rootfs
type=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 28644k/32768k available (2323k kernel code, 4124k reserve
d, 610k data, 264k init, 0k highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] NET: Registered protocol family 16
[    0.100000] MIPS: machine is TP-LINK TL-MR3220
[    0.500000] registering PCI controller with io_map_base unset
[    0.540000] bio: create slab <bio-0> at 0
[    0.550000] PCI host bridge to bus 0000:00
[    0.550000] pci_bus 0000:00: root bus resource [mem 0x10000000-0x13ffffff]
[    0.560000] pci_bus 0000:00: root bus resource [io  0x0000]
[    0.560000] pci_bus 0000:00: No busn resource found for root bus, will use [b
us 00-ff]
[    0.570000] pci 0000:00:00.0: fixup device configuration
[    0.570000] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x1000ffff 64bi
t]
[    0.580000] pci 0000:00:00.0: using irq 40 for pin 1
[    0.580000] Switching to clocksource MIPS
[    0.590000] NET: Registered protocol family 2
[    0.590000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[    0.600000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[    0.610000] TCP: Hash tables configured (established 512 bind 512)
[    0.610000] TCP: reno registered
[    0.620000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.620000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.630000] NET: Registered protocol family 1
[    0.650000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.660000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORIT
Y) (c) 2001-2006 Red Hat, Inc.
[    0.670000] msgmni has been set to 55
[    0.670000] io scheduler noop registered
[    0.680000] io scheduler deadline registered (default)
[    0.680000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.720000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[    0.720000] console [ttyS0] enabled, bootconsole disabled
[    0.720000] console [ttyS0] enabled, bootconsole disabled
[    0.740000] ath79-spi ath79-spi: master is unqueued, this is deprecated
[    0.740000] m25p80 spi0.0: found s25sl032p, expected m25p80
[    0.750000] m25p80 spi0.0: s25sl032p (4096 Kbytes)
[    0.760000] 5 tp-link partitions found on MTD device spi0.0
[    0.760000] Creating 5 MTD partitions on "spi0.0":
[    0.770000] 0x000000000000-0x000000020000 : "u-boot"
[    0.770000] 0x000000020000-0x000000126a00 : "kernel"
[    0.780000] mtd: partition "kernel" must either start or end on erase block b
oundary or be smaller than an erase block -- forcing read-only
[    0.790000] 0x000000126a00-0x0000003f0000 : "rootfs"
[    0.800000] mtd: partition "rootfs" must either start or end on erase block b
oundary or be smaller than an erase block -- forcing read-only
[    0.810000] mtd: device 2 (rootfs) set to be root filesystem
[    0.820000] 1 squashfs-split partitions found on MTD device rootfs
[    0.820000] 0x0000002f0000-0x0000003f0000 : "rootfs_data"
[    0.830000] 0x0000003f0000-0x000000400000 : "art"
[    0.840000] 0x000000020000-0x0000003f0000 : "firmware"
[    0.860000] libphy: ag71xx_mdio: probed
[    1.410000] ag71xx-mdio.1: Found an AR7240/AR9330 built-in switch
[    2.450000] eth0: Atheros AG71xx at 0xba000000, irq 5, mode:GMII
[    3.000000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd0
41, driver=Generic PHY]
[    3.010000] eth1: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[    3.020000] TCP: cubic registered
[    3.020000] NET: Registered protocol family 17
[    3.030000] Bridge firewalling registered
[    3.030000] can: controller area network core (rev 20120528 abi 9)
[    3.040000] NET: Registered protocol family 29
[    3.040000] 8021q: 802.1Q VLAN Support v1.8
[    3.060000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    3.070000] Freeing unused kernel memory: 264K (8033e000 - 80380000)
procd: Console is alive
procd: - watchdog -
procd: - preinit -
[    6.280000] usbcore: registered new interface driver usbfs
[    6.300000] usbcore: registered new interface driver hub
[    6.300000] usbcore: registered new device driver usb
[    6.320000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    6.340000] ehci-platform: EHCI generic platform driver
[    6.340000] ehci-platform ehci-platform: EHCI Host Controller
[    6.350000] ehci-platform ehci-platform: new USB bus registered, assigned bus
 number 1
[    6.350000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[    6.380000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[    6.390000] hub 1-0:1.0: USB hub found
[    6.390000] hub 1-0:1.0: 1 port detected
[    6.400000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[    7.870000] eth0: link up (1000Mbps/Full duplex)
mount_root: jffs2 is ready
[    9.700000] jffs2: notice: (332) jffs2_build_xattr_subsystem: complete buildi
ng xattr subsystem, 15 of xdatum (0 unchecked, 14 orphan) and 95 of xref (0 dead
, 84 orphan) found.
[    9.730000] eth0: link down
procd: - early -
procd: - watchdog -
procd: - ubus -
procd: - init -
Please press Enter to activate this console.
[   10.710000] NET: Registered protocol family 10
[   10.730000] nf_conntrack version 0.5.0 (451 buckets, 1804 max)
[   10.740000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   10.770000] Loading modules backported from Linux version master-2013-11-05-0
-gafa3093
[   10.780000] Backport generated by backports.git backports-20130802-0-gdb67a3f

[   10.790000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   10.840000] xt_time: kernel timezone is -0000
[   10.880000] cfg80211: Calling CRDA to update world regulatory domain
[   10.880000] cfg80211: World regulatory domain updated:
[   10.890000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gai
n, max_eirp)
[   10.900000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 20
00 mBm)
[   10.900000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 20
00 mBm)
[   10.910000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 20
00 mBm)
[   10.920000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (300 mBi, 20
00 mBm)
[   10.930000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (300 mBi, 20
00 mBm)
[   10.930000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0
mBm)
[   11.020000] PPP generic driver version 2.4.2
[   11.020000] NET: Registered protocol family 24
[   11.080000] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[   11.120000] ieee80211 phy0: Atheros AR9285 Rev:2 mem=0xb0000000, irq=40
[   11.130000] cfg80211: Calling CRDA for country: US
[   11.130000] cfg80211: Regulatory domain changed to country: US
[   11.140000] cfg80211:  DFS Master region FCC
[   11.140000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gai
n, max_eirp)
[   11.150000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 27
00 mBm)
[   11.160000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (300 mBi, 17
00 mBm)
[   11.170000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz), (300 mBi, 24
00 mBm)
[   11.180000] cfg80211:   (5490000 KHz - 5600000 KHz @ 80000 KHz), (300 mBi, 24
00 mBm)
[   11.180000] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 24
00 mBm)
[   11.190000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (300 mBi, 30
00 mBm)
[   11.200000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 40
00 mBm)
procd: - init complete -
[   18.540000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   18.540000] device eth0 entered promiscuous mode
[   18.550000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   18.560000] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   19.640000] eth0: link up (1000Mbps/Full duplex)
[   19.640000] br-lan: port 1(eth0) entered forwarding state
[   19.650000] br-lan: port 1(eth0) entered forwarding state
[   19.650000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   19.660000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   21.650000] br-lan: port 1(eth0) entered forwarding state

#d>>^F~v               ‘óæHÌ&fææææ^F^@^@Please press Enter to activate this con
sole.
y^@^@y^@^@^O^@^@@$‘I¿>^^if“fæææ^F^@^@Please press Enter to activate this console
.

Ma scusa perchè non l’hai detto prima che stavi usando OpenWrt?
Vedo come data Sun Dec 22 23:59:53 MST 2013, l’hai compilato tu o hai scaricato uno snapshot dal trunk?
La versione scaricata dal trunk non ha installato LuCI e quindi niente interfaccia web.
Vuoi rimettere il firmware originale?

si voglio rimettere il firmware originale

Puoi usare il failsafe per ritornare al firmware originale e non dovrebbe servire la seriale.
Scarica il firmware originale SENZA la stringa “boot” nel nome del file e facendo attenzione alla versione hardware, nel tuo caso va bene questo: http://www.tp-link.com/Resources/software/TL-MR3220_V1_120523.zip
Scarica un file server http (ti consiglio HFS) e Putty, segui questi passaggi:

  1. Scollega la seriale, disattiva il wireless, imposta la scheda di rete lan del pc con ip statico 192.168.1.10 e collega il router usando una porta lan.
  2. Accendi il router e premi il tasto QSS non appena il led SYS inizia a lampeggiare, OpenWrt andrà in FailSafe.
  3. Estrai il firmware che hai scaricato e rinominalo per comodità in firmware.bin
  4. Apri HFS, tasto destro nella parte sinistra e poi add files, seleziona il firmware (file firmware.bin)
  5. Apri Putty e collegati usando il protocollo telnet al router (ip 192.168.1.1)
  6. Scrivi il seguente comando e dai invio
cd /tmp
  1. Scrivi il seguente comando e dai invio
wget http://192.168.1.10/firmware.bin
  1. Scrivi il seguente comando e dai invio
mtd -r write /tmp/firmware.bin firmware
  1. Terminata la scrittura il router dovrebbe riavviarsi con il firmware orginale.

ciao effeti o fatto come ai detto. ecco cosa esce BusyBox v1.19.4 (2013-12-22 23:48:36 MST) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.


| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -| || | | || || |
|
_____|| |
||||___||| |____|
|
| W I R E L E S S F R E E D O M

BARRIER BREAKER (Bleeding Edge, r39155)

  • 1/2 oz Galliano Pour all ingredients into
  • 4 oz cold Coffee an irish coffee mug filled
  • 1 1/2 oz Dark Rum with crushed ice. Stir.
  • 2 tsp. Creme de Cacao

[email protected]:/# cd /tmp
[email protected]:/tmp# wget http://192.168.1.10/firmware.bin
Connecting to 192.168.1.10 (192.168.1.10:80)
wget: server returned error: HTTP/1.1 404 Not Found
[email protected]:/tmp# mtd -r write /tmp/firmware.bin firmware
Couldn’t open image file: /tmp/firmware.bin!
[email protected]:/tmp# non riesco a mandare il firmware ? qualche consiglio?

Non trova il firmware, hai aggiunto il file firmware.bin su HFS?
Hai collegato il cavo di rete e impostato la connessione lan del pc con ip statico 192.168.1.10?
Disattiva il firewall

si era tutto come dici

Il led SYS lampeggia molto velocemente? (FailSafe)
Se sei collegato con telnet la connessione LAN dovrebbe essere ok, il problema è in qualche impostazione di HFS o nel firewall di windows.
Ma non è che hai altre connessioni attive?
Apri HFS nella barra degli indirizzi in alto devi vedere come indirizzo http://192.168.1.10 se hai attivo il wi-fi o altre connessioni l’indirizzo cambia, devi disattivarle e lasciare solo la LAN.

Il led SYS lampeggia molto velocemente? – si e poi diventa fisso Ma non è che hai altre connessioni attive – quando mi collego spengo tutte le connessioni . ora riprovo di nuovo

Dovrebbe continuare a lampeggiare, quando diventa fisso vuol dire che ha finito di “caricare” il firmware quindi non sei in failsafe.
Spegni il router, accendilo, il led sys inizia a lampeggiare, aspetti 2 secondi e premi qss.
Comunque se riesci ad entrare con telnet non è questo il problema.

ora mi esce questo …Welcome to GoodTech Systems Telnet Server for Windows NT/2000/XP (Evaluation Cop
y)

(C) Copyright 1996-2002 GoodTech Systems, Inc.


Login username: cd /tmp
Login password: *************************************
Domain name: mtd -r write /tmp/firmware.bin firmware
Authentication is in progress…
Login failed…

Login username:

sono riuscito ad far lampeggiare ++veloce la sys ma non riesco a mandare il firmw…mi da sempre questo errore
wget: server returned error: HTTP/1.1 404 Not Found 0 403 ? tutto qua ma esiste un altro metodo

Risolto da remoto.
Sbagliavi due cose:

  • Il nome del file era firmware.bin.bin e non firmware.bin
  • Hai inserito in qualche modo l’ip del router nella lista dei client bannati in HFS (ecco perchè dava errore 403) :open_mouth:

Ora è tutto ok :wink:

e per uno non esperto questo e il risultato .ti ringrazio dinuovo .

hai un conflitto di IP.

collega SOLO il tp-link con il cavo LAN al pc. disabilita qualsiasi altra scheda di rete del pc che non sia la Ethernet da “gestione dispositivi” o da “schede di rete”…