configurazione porte td8811 + wr1043nd

Ciao a tutti, avrei bisogno possibilmente del vostro aiuto.

Ho una linea adsl TISCALI PPPOA, un modem/router td8811 e un router wr1043nd con dd-wrt installato.

Vorrei riuscire ad accedere dall’esterno ad un pc nella rete LAN di casa mia.
IL td8811 l’ho configurato in base alle impostazione di tiscali con indirizzo 192.168.0.1, il router wr1043nd l’ho configurato con dhcp automatico e indirizzo 192.168.1.1, fin qui tutto bene, navigo tranquillamente.
Il problema mi si presenta quando devo configurare le porte del td8811 e del wr1043nd per accesso dall’esterno, ve la faccio breve non sono molto capace, faccio confusione, io imposto nel 8811 in virtual server la porta che mi interessa con ip 192.168.0.100, e poi nel wr1043nd in NAT forwarding porte apro le stesse porte con indirizzo ip del PC, dico giusto?
Ma non funziona… azz… mi sapreste aiutare?

dovrebbe funzionare… ma io proverei la modalità “half bridge”, abilitando il “ppp ip extension” sulle impostazione del PPPoA del td-8811.
In questo modo al wr1043nd arriva direttamente l’ip pubblico sul lato WAN, dovrebbe essere una configurazione migliore anche dal punto di vista prestazionale.

La configurazione che hai fatto tu con il doppio NAT dovrebbe comunque funzionare.

Per comodità potresti abilitare il DMZ del td-8811 sull’ip del wr1043nd (hai scritto 192.168.0.100, ma converrebbe impostarlo statico sulle impostazioni WAN del wr1043nd, ad esempio 192.168.0.2).
Con il DMZ non dovresti più aver bisogno di aprire le porte sul td-8811 e faresti tutto dal wr1043nd.

P.S. ti trovi bene con il td-8811? cade mai la linea?

intanto ti ringrazio tanto per le info che mi hai dato, la connessione è stabile non mi cade mai, su quello non posso lamentarmi.
Ma impostando la modalità bridge, essendo pppoa come faccio dopo sul wr1043nd?
TI spiego meglio, impostando la connessione in bridge, i dati userid e password di tiscali, li devo inserire nel wr1043nd e non più nell’8811, giusto?

no no, si chiama half-bridge proprio per questo.
La PPPoA la instaura il modem, pero’ “passa” l’ip pubblico direttamente al router, che va impostato in dhcp sul lato WAN (quindi come adesso da quel che ho capito) :wink:

ahh ok ho fatto la prima parte, quella di mettere ppoa con opzione ppp ip, ora ho nel router l’indirizzo ip di tiscali, spero di essermi spiegato.

ora volevo chiederti come impostare l’ip fisso del modem nel wr1043nd.
ma nel modem devo impostare l’ip fisso? oppure lascio dhcp?
la parte del DMZ la devo fare, oppure apro le porte?

no spetta
Se ora hai l’ip di tiscali nella wan del wr1043nd sei apposto non devi toccare altro.
DEVE funzionare il virtual server, configurato solo sul wr1043nd…
sicuro che non sia il firewall del pc vero?

P.S. mi sa che adesso non riesci più ad accedere al td-8811, ma non dovrebbe essere un problema XD

stavo proprio per scrivere quello che hai detto tu, ho notato che ora non ho piu la parte del virtual server nel 8811 cioè il NAt, dico giusto?

quindi ora devo configurare il NAt del 1043, giusto?
la parte port Nat forwarding port? come prima?

ostrega hai ragione non accedo più al modem, come mai?

ehm… non è facile da spiegare XD

comunque ci sono 2 opzioni, abilitare il “secondary ip” dalla schermata LAN del td-8811, e metterlo su un’altra subnet tipo 192.168.2.1, oppure abilitare il remote management e accederci da uno di quei siti di “proxy anonimi” inserendo il proprio ip pubblico.
la prima è decisamente più comoda (se funziona).

resta il fatto che non dovresti più aver nemmeno bisogno di accederci.
non ho capito cosa intendi “configurare il NAT del 1043”
Vai su Forwarding->Virtual Server, inserisci la porta/e che ti servono e l’IP del pc (possibilmente impostato statico dalle proprietà della scheda di rete).
Avevo capito che questo l’avevi già fatto all’inizio!!

P.S. esco, a stasera…

avevi capito giusto, lo avevo fatto poi ho resettato tutto, ora lo rifaccio.
Dicevo NAT del 1043nd perchè ho installato il dd-wrt nel router e la parte del virtual server nel 1043nd non si chiama cosi, per quello che chiedevo se era giusto inserire le porte sotto NAT, forwardng port. oppure sono io che non vedo il virtual server… capito?

hai ragionissima scusa, mi ero scordato di DD-WRT!

quindi il virtual server sarebbe il NAT port forwarding?

siccome ho l’indirizzo ip che cambia, mi sarei appoggiato al servizio dyndns, questo dove va configurato ora? nel router o nel modem?
grazie per la pazienza

sì il menu è quello…

dyndns lo puoi impostare nel router :wink:
ma apparte l’indirizzo ip, hai capito se il port forward funziona??

http://portforward.com/help/portcheck.htm

ciao

sinceramente il port forwarding per me non va, non capisco dove sbaglio.

l’ip del pc sul quale forwardi le porte è impostato statico?
hai provato con 2 pc diversi (per escludere eventuali problemi sw)?

che build hai di dd-wrt? perche’ qui per esempio pare che non gli funzionasse…

http://www.dd-wrt.com/phpBB2/viewtopic.php?p=609953

si ho fatto quelle prove, aspe che ora riprovo…
infatti prima avevo quello built, ora ho aggiornato alla 17201 e riprovo

dopo il cambio firmware fai sempre un reset delle impostazioni del router :wink:
esco… a (molto) + tardi :wink:

fatto il reset, riconfigurato, ma non va nulla. azz…

allora sono andato in port forwarding, imposto come source net 192.168.0.100, dall porta 7575 alla porta 7575, su ip 192.168.1.112, sarebbe il mio pc, flag su abilita, salvo applico testo con il programma che mi hai consigliato, ma mi dice che le porte non è aperta… azzz…
grazie buona serata

ma noooo perche’ hai messo source net?? va lasciato vuoto :stuck_out_tongue:

tra l’altro c’era uno screenshot nel topic che ti ho linkato prima ^^

ok allora ti aggiorno, il sourc net l’ho lasciato perdere, pero ho avuto un pò di problemi…

alcune porte le apriva, altre no, poi quelle che diceva che erano aperte dopo un pò non lo erano più, ho riaggiornato e non andava nulla. quindi ho rimesso l’ultimo firmware originale TP-LINK, e con i vari test con pfportchecker, tutte le porte che volevo le ha aperte, senza problemi, al primo colpo.
Per ora rimarro al firmware originale.
Ora ho il problema dell’accesso dall’esterno, ho provato a inserire i dati di dyndns.org nel router e il servizio effettua il login con successo, ma dall’esterno non riesco ad entrare, per l’accesso utilizzo remoteHD sull’iphone, l’ho installato anche sul pc che voglio raggiungere, ma non riesco.
Ho effettuato il test di accesso dall’esterno che prevede il software, con esito positivo.

boh poi oggi riprovo con un po più di calma, grazie ancora dell’aiuto.

eh… misteri del dd-wrt… non saprei come spiegarlo se non dicendoti che sono tutti firmware beta e pieni di bug (segnalati di continuo), ci vorranno anni prima di averne uno stabile XD
Forse openwrt è migliore sotto quest’aspetto, li vedo molto più “attivi”, pero’ d’altra parte non ha la “semplicità” di dd-wrt.

Per verificare che il dyndns funzioni bene, ti basta abilitare il remote management sul wr1043nd, in modo che dall’esterno inserendo nel browser http://tuonome.dyndns.org dovrebbe presentarsi il login del router (ovviamente cambiagli la password!).

A quel punto non saprei come aiutarti per quanto riguarda il tuo programma, ma almeno il router l’abbiamo sistemato ^^
Hai provato anche direttamente con l’ip pubblico invece del nome con dyndns?