configurare tl wa801nd con Netbook Ubuntu

Ciao a tutti, chiedo scusa in anticipo…ho letti svariati post ma non sono riuscita a configurare l’AP in questione! forse credo di aver capito pure il problema…gli IP, che purtroppo non capisco per niente! c’è qualche anima pia che mi da una mano? a proposito, vorrei utilizzarlo come client per la mia smart tv, prendendo la wifi dal router thomson gateway (infostrada)

Ci sto perdendo davvero la testa! spiego la procedura e spero di essere chiara…
Come da manuale cambio l’ip della connessione via cavo in: IP 192.168.1.100 Maschera 255.255.255.0 Gateway 192.168.0.254. Collego l’AP avvio il browser e digito 192.168.0.254 e non si apre la pag del dispositivo! rimetto IP del pc in automatico, apro il browser digito… e si apre la pag di setup! allora impostp Operation mode su Client.
Wireless Setting cliccso Surwey mi trova la wifi 35 db clicco su connect, assegna il MAC in auto, region Italy, wireless security mode Most secure (WPA/WPA2/-PSK), inserisco la stessa password, next.
Network Setting: non tocco nulla, DHCP disable, ip andress 192.168.0.254, subnet mask 255.255.255.0 e next.
Finish riepilogo, salvo, finish, restart.
SI riavvia, ma non funziona, non riceve e non invia…dove sbaglio???

  1. la scheda di rete ottiene un indirizzo ip valido dopo la cfg?
  2. # ifconfig eth0 che dice?
  3. eventuale filtro mac attivo sull’ap base?
  4. nel wa801nd, nella sezione Wireless - Wireless Statistics, cosa appare? [dovresti avere una voce con AP-UP ed una con STA-ASSOC o WPA(2)-PSK, WPA(2)-Personal]

Appena ho un po’ di tempo controllo e posto i risultati! Grazie per l’aiuto!!

Ovvio che non si apre la pagina di config, stai chiamando una classe ip diversa …
Quello che ti serve sapere prima di tutto è che classe di ip ha il router di infostrada. Poi dovrai modificare quelli dell’AP client di conseguenza. Non puoi metterli a caso. Attenzione che se metti IP fisso diverso e anche ti connetti al router principale non navighi.

Eccomi! dopo la modifica ifconfig e con AP collegata mi da questo

Link encap:Ethernet IndirizzoHW 00:1e:68:b5:84:ad
indirizzo inet:192.168.1.100 Bcast:192.168.1.255 Maschera:255.255.255.0
indirizzo inet6: fe80::21e:68ff:feb5:84ad/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1 errors:0 dropped:1 overruns:0 frame:0
TX packets:208 errors:0 dropped:0 overruns:0 carrier:0
collisioni:0 txqueuelen:1000
Byte RX:60 (60.0 B) Byte TX:9548 (9.5 KB)

Nell ap base non c’è protezione questo è un copia e incolla:

Protezione
Consenti nuovi dispositivi: Sono consentite nuove stazioni (automaticamente)

Modalità di protezione: WPA-PSK
Ciao sigma! l’indirizzo ip del router è 151.73.88.157.

ehm, mi sembra di non vedere il gateway. hai reimpostato i parametri della scheda di rete in automatico?
prova a farlo nel modo previsto dalla tua distribuzione; al limite prova a dare (da root) dhclient e poi ricontrolla se ifconfig eth0 tira fuori anche il gateway.

eventualmente, potresti dover modificare /etc/resolv.conf (o quello che è) inserendo la riga:

nameserver 8.8.8.8

ok.

Grazie fabio nper la pazienza! ho appena inserito nameserver 8.8.8.8 nel fila, ma il gateway non compare in ifconfig…

approfittane finché ne ho :stuck_out_tongue:

e diciamo che per ora il dns dovrebbe essere a posto

-.-

che so, boh, disabilita e riabilita la scheda

ifconfig eth0 down

ifconfig eth0 up

dhclient che dice o che fa?

eth0 Link encap:Ethernet IndirizzoHW 00:1e:68:b5:84:ad
indirizzo inet:192.168.1.100 Bcast:192.168.1.255 Maschera:255.255.255.0
indirizzo inet6: fe80::21e:68ff:feb5:84ad/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:535 errors:0 dropped:0 overruns:0 frame:0
TX packets:1624 errors:0 dropped:0 overruns:0 carrier:0
collisioni:0 txqueuelen:1000
Byte RX:52546 (52.5 KB) Byte TX:124991 (124.9 KB)

questo è quello che esce fuori da ifconfig

mentre con dhclient mi da operazione non consentita! mi sa che recupero xp…

-.-

:dodgy:

stai eseguendo quella roba come root?
su ubuntu dovrebbe bastare sudo -s per acquisirne i privilegi.

mmm…con sudo mi da file exsist…buon segno??

u’r drivin’ me nuts :frowning:

$ sudo ifconfig eth0 down

fatto?

da quando ifconfig mostra il gateway?? io l’ho sempre visto e modificato con “route”…

e poi che centra il gateway del pc per configurare l’ap??

comincio ad avere le idee confuse :frowning:

allora ricordavo male :-/
non è recente il mio ultimo smanettamento con gli unix-like.

f**k, ero convinto che l’avesse già configurato :dodgy:
sto male.

io di più. ho bisogno di una pausa. mi asterrò per un po’.

vi chiedo scusa ragazzi! sono un tantino inesperta con linux…digitando route compare il gateway come per magia! incollo:
Tabella di routing IP del kernel
Destination Gateway Genmask Flags Metric Ref Use Iface
default 192.168.0.254 0.0.0.0 UG 0 0 0 eth0
192.168.0.254 * 255.255.255.255 UH 0 0 0 eth0
192.168.1.0 * 255.255.255.0 U 1 0 0 eth0
192.168.1.0 * 255.255.255.0 U 9 0 0 wlan0

Per me è arabo…ci sto perdendo la testa! perchè non entro nella pagina di configurazione?

no…dai! non astenetevi proprio adesso!!!

:frowning: Ragazzi vi chiedo scusa per avervi confuso le idee…credo abbiate capito il mio livello di conoscenza dell’AP, lubuntu, router e IP! :frowning:
Posso chiedervi una mano a configurare questo benedetto AP? magari iniziando tutto da capo…abbiate pietà per favore!

:*
lol

mo’ che arriva nebbia88 mi spara.

  1. assegnazione dell’indirizzo ip al pc:
    $ sudo ifconfig eth0 192.168.1.5 netmask 255.255.255.0

  2. punta il browser su http://192.168.1.254
    user/pass: admin/admin

fatto?

lol

Ciao ragazzi!! devo ringraziarvi per avermi aiutato, in particolare Nebbia che, con tanta pazienza, mi ha guidato passo dopo passo…l’ap funziona QUASI perfettamente, quasi perchè il mio intento era quello di collegare la mia smart tv all’Ap in modalità Client! e c’ero pure riuscita, impostando i dati Ip manualmente e dopo vari tentativi, la tv si è connessa, aggiornata e, giusto per non farmi mancare niente, non si è connessa più! mha…da un problema all’ altro!
Visto che ci siamo, qualcuno c’è riuscito a collegarlo alla propria TV? possiibile che sono l’unica ad aver avuto questa brillante idea???