Condivisione rete

Ciao a tutti! Mi chiamo Mattia e avrei bisogno di un aiuto.
In parole povere vorrei riuscire ad accedere ai file condivisi su iTunes dal router che ho in una parte della casa tuttavia non riesco a impostare come si deve le cose. La rete è composta dal modem a cui sono collegati powerline (TL-PA211) e computer, in output (in un’altra zona della casa) è collegato ad un router (TL-WR1042ND).
Lo schema più o meno è questo:
router <----> powerline <----> ADSL <----> computer
Io vorrei:

  1. accedere ai file condivisi dal computer
  2. poter modificare le impostazioni del router dal computer
    È fattibile come cosa?
    Grazie in anticipo a chiunque riesca ad aiutarmi!
    Ciao

Ciao modello o indirizzo ip del router adsl?

Il modem è una vodafone station con indirizzo ip 192.168.1.1, il router invece era 192.168.0.1 ma mi sembra di averlo combinato in 192.168.0.2 per essere certo che non andasse ad interferire.
Le porte per la condivisione dovrebbero essere 3689 e 5353, forse sbaglio io le impostazioni… non so…
Grazie!

Se il modem è 192.168.1.1 dai al TL-WR1042ND 192.168.1.2, disattiva il server dhcp e upnp, collegalo usando la porta lan e non wan!

O.O era così semplice?! ahaha grazie mille! Ora avrei bisogno anche di un altro aiuto:
Al router era collegata una ipcam, posso collegarla anche via ethernet ad un’altra lan? Se rimane collegata in wifi non riesco ad accedervi.
In più ce n’è un’altra che riceve tutti e due i segnali (sia dal router che dall’adsl), prima bloccavo il mac address dal router e assegnavo l’ip statico a entrambe, questa con porta 81 e l’altra 82.
Funziona comunque così?
Infine, se volessi accedere all’interfaccia web del router come faccio?
Scusa la valanga di domande e grazie.

EDIT:
Sono riuscito a collegarmi all’interfaccia dopo il riavvio… e anche a bloccare il macaddress dal router.
Non riesco però ad accedere alla cam collegata al router. Anche impostandole l’ip statico .12 dall’adsl continua a prendersi il .102 e non c’è verso di farglielo cambiare…

Vuoi dire che hai prenotato l’ip con il dhcp del router?

E no perchè mi avevi detto di disattivarlo dal router. Gliel’ho riservato dal modem adsl.
Ho provato anche a riservargli il .102 ma me lo cambia comunque… un po’ strano…

Hai fatto bene, ho dimenticato di scrivere “adsl” :mrgreen:

Si è strano, hai disattivato il server dhcp del tp-link e cancellato tutte le prenotazioni?

Sisi! a questo punto non importa basta che tanto riesco ad accedere alla porta. Grazie mille ancora!